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1. Nuclei Studio IDE 简介与安装 

1.1. Nuclei Studio IDE 简介 

一款高效易用的集成开发环境（Integrated Development Environment，IDE）对于任何

MCU 都显得非常重要，软件开发人员需要借助 IDE 进行实际的项目开发与调试。ARM 的商业

IDE 软件 Keil，在中国大陆很多嵌入式软件工程师均对其非常熟悉。但是商业 IDE 软件（譬如

Keil）存在着授权以及收费的问题，各大 MCU 厂商也会推出自己的免费 IDE 供用户使用，譬如

瑞萨的 e2studio 和 NXP 的 LPCXpresso 等，这些 IDE 均是基于开源的 Eclipse 框架，Eclipse 几

乎成了开源免费 MCU IDE 的主流选择。Nuclei Studio IDE 正是芯来公司，基于 MCU Eclipse 

IDE 开发的一款针对芯来公司处理器核产品的集成开发环境工具。 

Eclipse 平台采用开放式源代码模式运作，并提供公共许可证（提供免费源代码）以及全球发

布权利。Eclipse 本身只是一个框架平台，除了 Eclipse 平台的运行时内核之外，其所有功能均位

于不同的插件中。开发人员既可通过 Eclipse 项目的不同插件来扩展平台功能，也可利用其他开发

人员提供的插件。一个插件可以插入另一个插件，从而实现最大程度的集成。 

Eclipse IDE 平台具备以下几方面的优势。 

◼ 社区规模大 

Eclipse 自 2001 年推出以来，已形成大规模社区，这为设计人员提供了许多资源，包括

图书、教程和网站等，以帮助他们利用 Eclipse 平台与工具提高工作效率。Eclipse 平台和相

关项目、插件等都能直接从 eclipse.org 网站下载获得。 

◼ 持续改进 

Eclipse 的开放式源代码平台帮助开发人员持续充分发挥大规模资源的优势。Eclipse 在

以下多个项目上不断改进。  

⚫ 平台项目——侧重于 Eclipse 本身。 

⚫ CDT 项目——侧重于 C/C++开发工具。 
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⚫ PDE 项目——侧重于插件开发环境。 

◼ 源码开源 

设计人员始终能获得源代码，总能修正工具的错误，它能帮助设计人员节省时间，自主

控制开发工作。 

◼ 兼容性 

Eclipse 平台采用 Java 语言编写，可在 Windows 与 Linux 等多种开发工作站上使用。开

放式源代码工具支持多种语言、多种平台以及多种厂商环境。 

◼ 可扩展性 

Eclipse 采用开放式、可扩展架构，它能够与 ClearCase、SlickEdit、Rational Rose 以及

其他统一建模语言（UML）套件等第三方扩展协同工作。此外，它还能与各种图形用户接口

（GUI）编辑器协同工作，并支持各种插件。 

Nuclei Studio 已经充分与 Nuclei SDK 整合，完全满足 SDK 的需要，可以方便快捷地新建模

板工程，快速修改工程设置选项。内置 Nuclei SDK 源代码，可根据模板需求自动添加。 

1.2. Nuclei Studio IDE 下载 

为了方便用户快速上手使用，本文档推荐使用预先整理好的 Nuclei Studio IDE 软件压缩包。

芯来公司已经将该软件压缩包上传至公司网站，具体地址为

https://www.nucleisys.com/download.php，如图 1-1 所示。 

用户可以在芯来科技公司网站的“下载中心”，根据用户开发环境，下载对应 Windows 或

Linux 的 NucleiStudio 压缩包（注意：芯来科技公司网站的下载中心，其内容会不断更新，用户

请自行选择使用最新版本或继续使用当前版本）。  

目前已在 Win 10 64 位系统，Ubuntu 18.04/20.04 和 Redhat7.6 64 位版本上验证测试，推

荐使用以上版本的系统。 

https://www.nucleisys.com/download.php
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图 1-1NucleiStudio IDE 软件包的下载界面 

 

1.3. Nuclei Studio IDE 安装 

当完成 NucleiStudio IDE 压缩软件包下载，解压后包含若干文件如图 1-2（解压路径中不可

包含中文），分别介绍如下。 

◼ NucleiStudio 软件包 

⚫ 该软件包中包含了 Nuclei Studio IDE 的软件。注意：具体版本以及文件名可能会不

断更新。 

◼ HBird_Driver.exe（2021.02 版本起不再提供） 



  

 

本文件所述内容的版权为芯来科技独家所有，未经芯来科技事先书面授权，不得传播、复制或披露本文件之全部或部分内容。  页码 13 

 

⚫ 仅 Windows 版提供，此文件为芯来蜂鸟调试器的 USB 驱动安装文件。 

⚫ 当在 Windows 环境下，使用该调试器时，需要安装此驱动使该 USB 设备能够被系统

识别。 

⚫ 由于 2021.02 版本中更新的 openocd 引入了免驱功能。 

◼ SerialDebugging_Tool（2021.02 版本起不再提供） 

⚫ 仅 Windows 版提供，此文件为“串口调试助手”软件。此软件可以用于后续软件示

例调试时通过串口打印信息。 

 

图 1-2NucleiStudio IDE 压缩包文件内容 

 

2. 启动 Nuclei Studio 

启动 Nuclei Studio 的要点如下（windows 和 linux 均按照如下操作）： 

◼ 直接双击 NucleiStudio IDE 文件包中 NucleiStudio 文件夹下面的可执行文件，即可启动

Nuclei Studio，如图 2-1 所示。 

◼ 第一次启动 Nuclei Studio 后，将会弹出对话框要求设置 Workspace 目录路径，该目录将

用于存放后续创建的项目工程文件，如图 2-2 所示。 

◼ 设置好 Workspace 目录之后，单击“Launch”按钮，将会启动 Nuclei Studio。第一次

启动后的 Nuclei Studio 界面如图 2-3 所示。 

◼ 2021.02 版本 Nuclei Studio 默认关闭了 Launch Bar，请参照 9.1 开启 Nuclei 

Studio 中的 Launch Bar 功能，方便快速编译调试和下载。 
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图 2-1 双击“NucleiStudio.exe”启动 Nuclei Studio 

 

图 2-2 设置 Nuclei Studio 的 Workspace 目录 
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图 2-3 第一次启动 Nuclei Studio 界面 

3. Nuclei Studio 更新说明 

Nuclei Studio 自 2021.09 版后，将 IDE 与 SDK 完全分离，将采用全新的 Nuclei 

Package(NPK)的包管理的方式进行模板工程的管理和使用，方便用户进行不同 SDK 的导入并

且在 IDE 上创建示例工程并使用，针对 Nuclei SDK 和 HBird SDK 以及我们公司的 SoC IP 产

品提供的 SDK，均可以打包成 Zip 包的方式以通过 Nuclei Package Management 方式进行导入

使用。  

4. Nuclei Studio NPK 功能 

Nuclei Studio 中内建了对 Nuclei Package（NPK）功能的完整支持，方便开发者或者创建不

同的软件开发包，并且通过 Nuclei Package Management 方式导入到 Nuclei Studio 中使用，

如果是 CPU IP 客户，可以将自己的芯片 SDK 略作改造以支持 NPK，并导入到 Nuclei Studio

中使用，如果是 SoC IP 客户，可以将提供的 SDK 打包成 Zip 包，导入使用，如果是开发者，
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也可以依赖某个特定的 NPK，创建对应的 BSP 包或者 APP 包并提供给第三方使用，关于 NPK

功能的详细介绍，以及后续更新说明参见 https://github.com/Nuclei-Software/nuclei-

sdk/wiki/Nuclei-Studio-NPK-Introduction。通过在原有的 SDK 中引入 npk 功能，编写

npk.yml 可以达到 Project Wizard 功能的部分定制化。 

开发者要使用 Nuclei Studio 进行工程的创建，需先将对应的 SDK NPK Zip 包安装到 IDE

中，方可根据不同的开发板快速新建不同的模板工程，并根据不同的模板添加需要的 SDK 源

码，根据选项生成不同的编译链接选项设置。 

4.1.通过 NPK 创建工程 

本章将在 RVSTAR 开发板上，以新建和修改 GD32VF103 的工程为例快速介绍 Nuclei Studio

功能，RVSTAR 开发板开发需要使用 nuclei_sdk 的 npk 包，详细的流程请参考之后的章节。 

◼ 在 Nuclei Studio 中最大的更新，就是将 npk 云端化，用户直接在 Nuclei Studio 中就可

以下查看到所有的 npk 并自行安装，在菜单栏选择“RV-Tools-->Nuclei Package 

Management”在弹出的 Nuclei Package Management 管理页进行 npk 管理如图 4-3。

在 Nuclei Package Management 页面，先点击一下 Refresh 获取最新的 npk 信息，npk

安装前状态为 Not Installed 然后选中自己想要安装的 npk,点击 Download 进行安装，本

教程安装 sdk-nuclei_sdk 的最新版本 0.3.7，安装完成后 npk 状态变为。 

https://github.com/Nuclei-Software/nuclei-sdk/wiki/Nuclei-Studio-NPK-Introduction
https://github.com/Nuclei-Software/nuclei-sdk/wiki/Nuclei-Studio-NPK-Introduction
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图 4-1 进入 SDK Manage  
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图 4-2 导入资源包 
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图 4-3 资源包管理 
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图 4-1 资源包管理 

◼ 新建一个工程，可以在菜单栏中，选择“File --> New --> New Nuclei RISC-V C/C++ 

Project”，如 图 4-1。也可以在 Project Explorer 视图中选中“New Nuclei RISC-V 

C/C++ Project” 
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图 4-2 使用菜单栏创建项目 

 

图 4-6 使用菜单栏创建项目 

◼ 如图 3-8 所示，在弹出的窗口中可以不同的厂商提供的不同版本的 SDK,选种某一 Board

下的 SDK,看到相关 SoC 及 Board 的介绍。这里以 RVSTAR 开发板为例，所以这一项选

择“GigaDevice->GD32VF103->Nuclei GD32VF103 RVSTAR Board->sdk-

nuclei_sdk@0.3.7” 。点击“Next”进入下一步。（注意：这里的 sdk 版本号会随着版
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本迭代做相应的更新，并且也可能依赖特定版本的 Nuclei Studio 使用） 

 

图 4-3 选择建立项目类型 

◼ 进入具体的项目配置页如图 3-9 所示，因为 RVSTAR 的内核是固定的 N205，其对应的

arch 和 abi 分别是 rv32imac 和 ilp32，所以 Core 选项不能修改。同样，RVSTAR 开发

板仅支持一种 FLASHXIP 下载模式，所以 DOWNLOAD 这一选项也不能修改。点击
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“Finish”完成工程创建。 

 

 

图 4-4 选择程序模板及相关设置项 

⚫ Nuclei Studio 可以根据不同的工程模板添加不同的 SDK 源码，例如 FreeRTOS 模板

工程会添加对应的 OS 内容，Demo_dsp 模板工程可以添加 NMSIS 库文件。关于

NMSIS 详细信息请参考（https://doc.nucleisys.com/nmsis/index.html）。这里以

Demo_dsp 为例，“Project Example”选择“baremetal_demo_dsp”。因为使用

dsp 工程，需要添加 NMSIS 库，所以“Libraries”选择“NMSIS DSP”。 

⚫ Nuclei Studio 可以根据新建工程时的选项自动设置工程的选项。这里选择不使用浮

点打印，所以“NEWLIB”选择“newlib-nano without float”。编译优化等级

“Optimization Level”选择“Optimize more（-O2）”。之后一直选择“Next”直

到“Finish”。 

https://doc.nucleisys.com/nmsis/index.html
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◼ Nuclei Studio 可以快速修改工程的设置选项。新建好的工程如图 3-10 所示，单击要修改

的工程名，右击打开右键菜单，选择“SDK Configuration Tools”打开设置选项工具。

如图 3-11，如果要修改编译优化等级，修改“Optimization Level”为“None（-

O0）”，点击“Save”修改选项。如图 3-12 修改成功后在修改后的工程处右击打开右键

菜单，选择“clean”清除一下工程，再点击锤子图标编译工程。注意：SDK 

Configuration Tools 修改编译配置后对调试配置（Debug Configurations）不生效，请手

动修改对应的调试配置。 

 

图 4-5 打开 SDK 设置工具 
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图 4-6 修改工程设置 
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图 4-7 清理工程并重新编译 

4.2.通过 NPK 导入工具 

NPK 包除了可以导入 SDK,还可以方便的导入各种工具包，来扩展 NucleiStudio 的能力，

2022.08 版本的 NucleiStudio 增加 NPK Tools 的支持，为增加组件包的可扩展性，以及在编译和

调试上使用更便捷，增加类型为 tool 的 npk 组件包。tool 组件包可包含 gcc,qemu,cmlink-gdb 等

内容，以 zip 包的形式导入到 IDE 去使用。 

以 tool-cmlink 包为例，一个工具包中有该工具的执行文件及 npk.yml，开发者在 npk.yml 文

件中对该工具做了一些简单的描述，如工具包的开发者、版本、支持的操作系统、可执行文件的

路径等，可能参考 图表 4-1 内容。然后将上述包压缩成一个 zip 文件，可以参考 4.1.章的内容，

将 npk tools 导入到 ide 中，或才共享的 www.rvmcu.com 网站上。 

◼ -bin 

◼ -bin\cmlink_gdbserver.exe 

◼ -npk.yml 

http://www.rvmcu.com/
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图表 4-2 

在 Nuclei Package Management 管理页中同样可以对 npk tools 进行管理，下载该组件包

后，打开任意调试界面，点击 Variables 可以查看到该 npk tools 对应的参数，直接选中对应的参

数就可以使用该工具了。 

 

图表 4-3 
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一般我们在 npk tool 中为该组件包扩展变量有 4 个，每个包存在一个包路径，引用为 npk 名

称-版本号，例如${tool-cmlink-1.0.0} 

其他变量的引用为 npk 名称-版本号-变量名，例如 ${tool-cmlink-1.0.0-proxy},${tool-

cmlink-1.0.0-system_proxy} 

当变量的 system 值为 true 时，额外新增一个不带版本号的变量，取最高版本的该变量，例

如${tool-cmlink-system_proxy} 

 

 

5. 创建项目 

这里以开发板为 Nuclei FPGA Evaluation Board，评估处理器内核为 N307(rv32imafc)为
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例，详细介绍 Nuclei Studio 中创建项目的常见方式。 

在 Nuclei Studio IDE 创建项目可以有以下几种常见方式： 

◼ 使用模板自动创建项目： 

⚫ 这是最简单快捷的方式，目前模板项目功能依赖于 Nuclei Studio NPK 功能，在导入

对应的 SDK NPK Zip 包，即可在 Nuclei Studio 上进行模板工程的创建。芯来科技提

供了 Nuclei SDK、HBird SDK、SoC IP SDK 的 NPK Zip 包，均可导入到 IDE 中进

行工程的创建和使用。 

◼ 从已有项目直接导入创建新项目： 

⚫ 这是最常见的方式，譬如，用户 A 可以将已有项目的文件夹直接进行打包保存，然后

进行分享传播，用户 B 可以在另外的电脑上直接导入该项目，从而以此为基础创建新

的项目，在此基础上直接使用或者开发修改。 

◼ 无模板手动创建项目： 

⚫ 这是最繁琐的方式，该方法除了创建项目之外，还需要手动设置各种选项和路径。由

于该方式比较繁琐，所以在实际工作中较少使用，但是通过该方式的详细讲解，用户

可以详细了解如何配置各中选项和路径。 

◼ 基于已有的 Makefile 创建项目： 

⚫ 这种方式比较适合于已经采用 Makefile 或者其他编译工具的项目，提供一种在 IDE

中编译工程，清理工程，调试工程的方式。在不修改编译系统的基础上，提供良好的

IDE 调试环境。 

下文将对这几种方式分别进行介绍。 

 

5.1.通过模板自动创建项目 



  

 

本文件所述内容的版权为芯来科技独家所有，未经芯来科技事先书面授权，不得传播、复制或披露本文件之全部或部分内容。  页码 30 

 

本节将介绍如何使用模板自动创建项目的方式，在 Nuclei Studio IDE 创建一个简单的 Hello 

World 项目，详细步骤如下。 

◼ 新建一个工程，可以在菜单栏中，选择“File --> New --> New Nuclei RISC-V C/C++ 

Project”，如图 4-1。也可以在 Project Explorer 视图中选中“New Nuclei RISC-V 

C/C++ Project” ，如图 4-2。 

 

 

图 5-1 从菜单创建项目 
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图 5-2 Project Explorer 视图创建项目 

◼ 如图 4-3 所示，在弹出的窗口中选择项目类型，这里我们在 Nuclei FPGA 板，内核是

N307，SDK 为 nuclei_sdk@0.3.7 版本来做一个测试开发，选对对应的 Board 下的

SDK, 点击“Next”进入下一步。 
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图 5-3 选择建立项目模型 

◼ 如图 5-2 所示，在弹出的窗口中设定如下参数（注意：此页面是通过 NPK 

Configuration 字段自动解析并生成的页面，不同的 SDK 或者不同的开发板或者不同

的例子都可能会有不同的选项页面，请注意）。 

⚫ Project name：项目命名。这里设置为“1_helloworld” 

⚫ Project Example：选 Helloworld。  

⚫ Toolchains：我们使用 Nuclei GUN Toolchain。  

⚫ 我们的内核是 N307，所以“Core”选择“N307”。 

⚫ 蜂鸟开发板支持三种下载模式，以下为每种下载模式的简介，这里我们选择 ILM 模

式。 

◼ ILM 下载模式程序将被直接下载在 MCU 的 ILM 中，并从 ILM 开始执行。ILM

由 SRAM 组成，会掉电丢失。 
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◼ FLASH 下载模式程序代码段的物理地址约束 Flash 区间，将代码段的逻辑地址约

束在 ILM 的地址区间，意味着程序将被直接下载在 MCU 的 Flash 中，但是上电

后要通过引导程序将代码段搬运到 ILM 中，然后从 ILM 中开始执行。程序被烧

写在 Flash 中，不会掉电丢失。 

◼ FLASHXIP 下载模式程序代码段约束 Flash 区间，意味着程序将被直接下载在

MCU 的 Flash 中，并直接从 Flash 开始执行。程序被烧写在 Flash 中，不会掉电

丢失。 

⚫ 其他各项可以按需进行配置 

⚫ 点击“Finish”完成工程创建。 
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图 5-2 新建项目及模板选择 

◼ 如图 5-3 所示，使用模板自动创建 Hello World 项目已经完成。 

 

图 5-3 完成模板创建项目 

◼ 用户可以直接使用菜单栏“Project—> Build Project”或“ ”按钮，来对该项目进行

编译，编译后如图 5-4。 
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图 5-4 完成项目编译 

◼ 如图 5-5 所示，在 Hello World 项目自动生成过程中，其对应的 OpenOCD 配置已经同

步完成。在项目编译完毕后，用户可以右键点击项目列表“Hello World”，点击

“Debug As —>Debug Configurations”开启调试配置面板进行查看。Debug 与 Run 使

用相同的配置文件，所以也可通过“Run As —>Run Configurations”打开。 
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图 5-5 开启调试配置面板 

◼ 如图 5-6 所示，用于调试使用的配置文件“Hello World_Debug_OpenOCD”已经自动

生成。关于使用芯来蜂鸟调试器结合 OpenOCD 进行下载和调试的方法，可以查看第 7

章进行详细了解。 
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图 5-6 自动生成的 OpenOCD 配置 

5.2.从已有项目直接导入创建新项目 

本节将介绍如何使用 IDE 从已有项目直接导入创建新项目，本文以 N307 的项目包为例进行

导入，项目包存放在（https://github.com/riscv-mcu/Nuclei-Studio_IDE-Project-Package）。如

图 5-7 所示，如需其它项目包请与芯来科技联系。 

在基于 Windows 的 Nuclei Studio IDE 开发环境中，如果用户使用“无模板手动创建工程”，

也需要加载此项目包中的 nuclei-sdk 文件夹，相关内容会在下一节中具体介绍。 

 

图 5-7 位于 github 上面的项目包 

https://github.com/riscv-mcu/Nuclei-Studio_IDE-Project-Package
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将 nuclei-eclipse_demo.rar 压缩包下载解压后，内容如图 5-8 所示，分别为： 

 

图 5-8 选择导入的项目 

◼ 项目包的描述文件.setting，.project 和.cproject 

◼ 项目包的 Debug 设置文件*.launch 

◼ nuclei_sdk 文件夹 

该文件夹下存放部分 SDK 源代码。 

◼ application 文件夹 

此文件夹包含 hello_world 样例程序的 main 函数源代码。 

 

下一步导入下载好的项目包，导入步骤如下： 

◼ 在菜单栏中选择“File—>import”。 

◼ 如图 5-9 所示，选择“Existing Project into WorkSpace”后，点击“Next”。 
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图 5-9 选择导入的方式 

◼ 点击“Browse”，选择需要导入的项目路径，如图 5-10 所示， 

  

图 5-10 选择需要导入的项目 
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◼ 需要的导入的项目成功被 IDE 识别，点击“Finish”如图 5-11 所示 

  

图 5-11 识别出要导入的项目 
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◼  在 IDE 的项目资源管理器中显示导入项目的目录结构如图 5-12 所示。已有项目默认为

N307 的编译选项，Nuclei SDK 仅包含 helloworld 使用到的文件。需要更多的 Nuclei 

SDK 源码请访问 Github（https://github.com/riscv-mcu/hbird-sdk）获取源码。 

  

图 5-12 显示项目的文件结构 

5.3.无模板手动创建项目 

本节将介绍如何使用手动方式在 Nuclei Studio IDE 创建一个用户自定义的 Hello World 项目

（不建议使用，建议使用 NPK 方式）。开发板为 Nuclei FPGA Evaluation Board，内核为

N307。该方法除了创建项目之外，还需要手动设置各种选项和路径，详细步骤如下。 

5.3.1. 手动创建项目 

◼ 在菜单栏中选择“File—> New —> C/C++ Project”。如图 5-13 所示。 

◼ 如图 5-14 所示，在弹出的窗口中设定如下参数。 

⚫ Project name：项目命名。 

⚫ Use default location：如果勾选了此选项，则会使用默认 Workspace 文件夹存放此

项目。 

⚫ Project type：选择“Hello World RISC-V C Project”。 

然后点击 Next 进入下一步 

◼ 如图 5-15 所示，在弹出的窗口中设置 Hello World 项目的基本信息。 

⚫ 确保“Source”选项内容为空，直接单击“Next”进入下一步。 
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◼ 如图 5-16 所示，在弹出的窗口中设置项目的调试或者发布属性。 

⚫ 该步骤可以使用默认信息不做任何修改，直接单击“Next”进入下一步。 

◼ 在弹出的窗口中设置项目所使用的 RISC-V 工具链。 

⚫ 此处不要配置，直接选择“Finish”，至此便完成了 Hello World 项目的创建。 

◼ 创建完成的 Hello World 项目界面如图 5-17 所示。 

◼ 新建一个 application 文件夹。如图 5-18，在工程处右击选择 New —> Folder，输入

application，点击“Finish”完成新建工程，如图 5-19。将 main.c 拖入 application 文

件夹完成文件分类。 

 

图 5-13 新建 C/C++ Project 
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图 5-14 设置 C Project 项目名和类型 

 

图 5-15 设置 Hello World 项目的基本信息 
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图 5-16 设置项目的调试或者发布属性 

 

图 5-17 创建完成 Hello World 项目的界面 
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图 5-18 打开新建文件夹 

 

图 5-19 完成新建文件夹 
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5.3.2. 配置项目的 nuclei_sdk 

本节介绍如何将 nuclei_sdk 加入到项目中，SDK 的具体内容本文不做详细介绍，可以参考

https://doc.nucleisys.com/nuclei_sdk/index.html。如果需要使用 SDK 的其他源文件，请到

Github 获取全部的 Nuclei SDK 源码（这里以 0.3.7 版本为例），链接如下：

https://github.com/Nuclei-Software/nuclei-sdk/releases 。本节仅介绍将 nuclei_sdk 中

helloworld 需要的文件加入到项目的步骤，具体步骤如下： 

⚫ 进入 Nuclei Studio 的 2_helloworld 项目，按照如下步骤添加 nuclei_sdk 源文件。 

◆ 如图 5-20 所示，在 Project Explorer 栏中选中 2_helloworld 项目，单击鼠标右

键，选择“Properties”打开工程设置页面。 

◆ 如图 5-21 所示，在弹出的窗口中单击“Resource”，在右侧的 Location 栏目中

单击其最右侧的箭头图标 ，则会弹出文件窗口进入 2_helloworld 项目的文件

夹位置。 

◆ 将图 5-7 中介绍的 nuclei-eclipse_demo.rar 压缩包中的 nuclei_sdk 文件夹复制

放于 2_helloworld 项目的目录下，如图 5-22 所示。 

◆ 回到 Nuclei Studio，在 Project Explorer 栏中选中 2_helloworld 项目，单击鼠标

右键，选择“Refresh”，如图 5-23 所示。 

◆ Refresh 之后 2_helloworld 项目的下便可以看到 nuclei_sdk 文件夹，如图 5-24

所示，至此便完成了 nuclei_sdk 源文件的导入。 

 

https://doc.nucleisys.com/nuclei_sdk/index.html
https://github.com/Nuclei-Software/nuclei-sdk/releases
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图 5-20 打开工程设置选项页面 

 

图 5-21 在弹出窗口进入 hello_world 项目的文件夹位置 
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图 5-22 添加 nuclei_sdk 文件夹 

 

图 5-23 刷新工程 
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图 5-24 新建项目目录下的文件夹 

5.3.3. 配置项目的编译和链接选项 

为了使项目源代码能够被正确编译，需要配置编译和链接选项。 

注意：本节中设置的编译与链接选项均为 GCC 工具链的常用选项，与在 Linux 环境中使用时

的同名选项含义一致，本节在此不做赘述介绍。 

配置编译与连接选项的步骤如下： 

◼ 在 Project Explorer 栏中选中 hello_world 项目，单击鼠标右键，选择“Properties”。 

◼ 在弹出的窗口中，展开 C/C++ Build 菜单，单击“Setting”，在右侧的 Tool Settings 栏

目中进行设置。 

◼ 如图 5-25 所示，选中 Target Processor，我们的内核是 N307，因此需要按照图所示勾选

配置选项，分别如下。 

⚫ Architecture：选择 RV32I。 
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⚫ Multiply extension（RVM）：需勾选。 

⚫ Atomic extension（RVA）：需勾选。 

⚫ Compressed extension（RVC）：需勾选。 

⚫ Integer API：选择“ILP32”。 

⚫ Floting Point ABI：选择 single precision 

⚫ Code model：选择“Medium Any”。 

⚫ 单击右下角的“Apply”按钮。 

 

图 5-25 配置 Target Processor 选项 

◼ 如图 5-26 所示，选中“Optimization”，按照图所示勾选配置选项。 



  

 

本文件所述内容的版权为芯来科技独家所有，未经芯来科技事先书面授权，不得传播、复制或披露本文件之全部或部分内容。  页码 51 

 

⚫ Optimization Level：选择 Optimization Most (-O2)。 

⚫ 依次勾选： 

◆ Function Sections (-ffunction-sections) 

◆ Data Sections (-fdata-sections) 

◆ No common unitialized (-fno-common) 

注意：上述选项均为通用的 GCC 编译优化选项，请用户自行查阅 GCC 手册了解其含

义。 

⚫ 单击右下角的“Apply”按钮。 

 

图 5-26 配置 Optimization 选项 
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◼ 如图 5-27 所示，选中 Debugging，按照图中所示勾选配置选项，分别为： 

⚫ Debug Level：选择 Default (-g)。 

⚫ 单击右下角的“Apply”按钮。 

 

图 5-27 配置 Debugging 选项 

◼ 选中 GNU RISC-V Cross C Linker 的 General。 

⚫ 如图 5-28 所示，按照如下步骤设置链接器的所需的链接脚本。 

◆ 选中右上角的加号按键。 

◆ 在弹出的窗口中单击“Workspace”按钮。 

◆ 这里我们使用 HummingBird 评估板，所以可以选择 ILM 下载模式对应的

gcc_hbird_ilm.ld 文件。在弹出的窗口中选择 NucleiStudio 文件包中的
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nuclei_sdk/SoC/hbird/Board/hbird_eval/Source/GCC 文件夹下 

gcc_hbird_ilm.ld 文件。其他下载模式切换此处文件，各文件详细介绍如下，可

根据自己的实际情况选择。 

⚫ gcc_hbird_ilm.ld 脚本将程序代码段约束在 ILM 的地址区间，意味着程序将

被直接下载在 MCU 的 ILM 中，并从 ILM 开始执行。ILM 由 SRAM 组成，

会掉电丢失。 

⚫ gcc_hbird_flash.ld 脚本程序代码段的物理地址约束 Flash 区间，将代码段的

逻辑地址约束在 ILM 的地址区间，意味着程序将被直接下载在 MCU 的

Flash 中，但是上电后要通过引导程序将代码段搬运到 ILM 中，然后从 ILM

中开始执行。 

⚫ gcc_hbird_flashxip.ld 脚本程序代码段约束 Flash 区间，意味着程序将被直

接下载在 MCU 的 Flash 中，并直接从 Flash 开始执行。程序被烧写在 Flash

中，不会掉电丢失。 

⚫ 用户可以按照自己的需求选择合适的链接脚本。本节示例选择

gcc_hbird_ilm.ld 作为演示。 

◆ 设置完毕请单击右下角的“Apply”按钮。 
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图 5-28 配置链接脚本 

◼ 如图 5-29 所示，按图所示勾选配置选项，分别如下。 

⚫ Do not use standard start files (-nostartfiles) 。 

⚫ Remove unused sections (--gc-sections)。 

⚫ 单击右下角的“Apply”按钮。 

⚫ 注意：上述选项均为通用的 GCC 链接选项，请用户自行查阅 GCC 手册了解其含义。 
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图 5-29 配置链接的 General 选项 

◼ 如图 5-30 所示，选中 GNU RISC-V Cross C Linker 的 Miscellaneous，按照图所示勾选

配置选项。 

⚫ 勾选“Use newlib-nano”。 

⚫ 因为 Hello World 程序的 Printf 不需要打印浮点数，所以不要勾选“Use float with 

nano printf”。 

⚫ 单击右下角的“Apply”按钮。 
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图 5-30 配置链接的 Miscellaneous 选项 

5.3.4. 配置项目的包含路径和文件 

为了能够正确编译 nuclei_sdk 文件夹中的源文件，需要按照如下步骤配置项目的包含路径和

包含文件。 

◼ 如图 5-20 所示，在 Project Explorer 栏中选中 hello_world 项目，点击鼠标右键，选择

“Properties”。 

◼ 在弹出的窗口中，展开 C/C++ Build 菜单，单击“Setting”，在右侧的 Tool Settings 栏

目中进行设置。  

◼ 如图 5-31 所示，选中 GNU RISC-V Cross C Assembler 的 Includes，按照图中所示配置

包含文件，步骤如下。 
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⚫ 在 Include paths 栏目单击加号键。 

⚫ 在弹出的窗口中单击“Workspace”，弹出 Folder selection 窗口。 

⚫ 在 Folder selection 窗口中选择项目的 nuclei_sdk 目录下的 NMSIS>Core>Include

文件夹。 

⚫ 在右下角单击“Apply”完成配置。 

◼ 采用上述方法，依次添加 nuclei_sdk 目录下的

SoC>hbird>Board>hbird_eval>Include，SoC>hbird>Common>Include 和

SoC>hbird>Common>Source>Stubs 文件夹作为包含路径，并采用同样的方法为 GNU 

RISC-V Cross C Compiler 的 Includes 栏目设置包含路径。设置完成后的界面如图 5-32

所示。 

 

图 5-31 设置 GNU RISC-V Cross C Assembler 的 Includes 栏目包含路径 
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图 5-32 设置 GNU RISC-V Cross C Compiler 的 Includes 栏目包含路径 

5.4.基于已有的 Makefile 创建项目 

本节将介绍如何使用已有的 Makefile 在 Nuclei Studio IDE 创建一个使用 Makefile 的 Hello 

World 项目。开发板为 Nuclei FPGA Evaluation Board，内核为 N307。请先下载 Nuclei SDK，

Github 链接为：https://github.com/Nuclei-Software/nuclei-sdk。该方法除了创建项目之外，还

需要手动设置各种选项和路径，这里以 helloworld 为例，详细步骤如下。 

5.4.1. 手动新建项目 

在菜单栏中选择“File—> New —> Makefile Project with Existing Code”。如图 5-33 所

示。 

如图 5-34 所示，在图标 1 处输入工程名，这里我们命名为 nuclei-sdk。在图标 2 处输入 SDK

的实际路径。在图标 3 处选择“RISC-V Cross GCC”。点击图标 4 完成新建项目。 

https://github.com/Nuclei-Software/nuclei-sdk
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图 5-33 新建基于 Makefile 的工程 

 

图 5-34 设置工程选项 
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5.4.2. 设置 Makefile 路径和 Build 选项 

右击新建好的工程，选择“Properties”打开设置页面，如图 5-35，选择“C/C++ Build”，

在“Build Location”中选择“Workspace”。在弹出的弹窗中选择“application –> baremetal 

–> helloworld”点击“OK”再点击“Apply”保存。  

 

图 5-35 配置 Makefile 路径 

 

如图 5-36，在“C/C++ Build”中选择“Behavior”栏目，确保勾选“Build（Incremental 

Build）”选项并输入“all CORE=n307 DOWNLOAD=ilm”。其中“CORE”选项根据实际的内

核变化，这里以 n307 为例。“DOWNLOAD”选项可以修改不同的下载模式，详细请参考 5.1

节，这里以 ilm 模式为例。因为例程使用 HummingBird Evaluation Board，所以 SoC 和 Board

都不必修改，如果使用其他开发板，以 RVSTAR 为例，请在此处设置增加“SOC=gd32vf103 

BOARD=gd32vf103v_rvstar”，并且由于 RVSTAR 仅支持 FLASHXIP 模式，需要将

“DOWNLOAD”设置为“flashxip”，同时“CORE”修改为“n205”。完成后点击“Apply”

保存修改。 
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图 5-36 配置 Build 选项 

在完成上述操作后，打开工具链配置页，如图 5-36，按图中配置，点击“Apply”保存修

改。 
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图 5-37 配置工具链路径 

编译运行以及下载的详细内容请参考 5、6 章。 

 

6. 编译项目 

6.1.Nuclei SDK 工程设置工具 

在 Nuclei Studio 中可以通过 Nuclei SDK 工程设置工具一键修改通过 Nuclei SDK Project 

Wizard 创建的工程的编译链接选项。本工具目前仅支持 Nuclei SDK，HBird SDK，Nuclei 

SoC IP SDK, 不支持无模板手动创建的项目和基于 Makefile 创建的项目, 或者是自行创建维

护的项目。详细使用步骤如下: 

单击选中需要修改的工程，之后如图 6-1 打开 RV-Tools>SDK Configuration Tools，可以打
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开修改编译选项的弹窗。也可以单击要修改的工程后，如图 6-2，点击工具栏的工程设置工具图

标。或者单击要修改的工程后，键盘按下 ctrl+6。也可以单击要修改的工程后，如图 6-3，右击

打开右键菜单，选择 SDK Configuration Tools。如图 6-4 为工程设置工具弹窗，各选项详细功能

如下： 

◼ projectName 为当前选中的工程名。 

◼ Core 为当前工程对应的内核。由于工具根据 ARCH 和 ABI 选项反推出对应的内核，而

不同的内核可能有相同的 ARCH 和 ABI 选项，所以显示上可能会有所偏差，只要 ARCH

与 ABI 为正确的选项即可。此选项为方便快速切换内核选项使用。 

◼ 四个勾选项：Bitmanipulation Extension(RVB), Cryptography Extension(RVK), Packed 

SIMD/DSP Extension, Vector Extension(RVV) 用于选择对应的扩展指令集(B/K/P/V) 

◼ ARCH 对应的当前工程的 arch 选项, 根据 Core 和勾选项自动组合。 

◼ ABI 对应的当前工程的 abi 选项。 

◼ Tuning 根据不同级别处理器优化的 gcc 选项，选择 Core 会自动选择正确的 Tuning 选

项，不建议自己调整。 

◼ Code Model 针对 RV32 处理器，自动选择为 Medium Low，而针对 RV64 处理器自动选

择为 Medium High，选择 Core 以后会自动选择合适的 Code Model，其中 RV64 处理器

必须使用 Medium High. 

◼ Download 对应当前工程的下载模式，可以切换选择不同的下载模式，目前仅 Nuclei 

FPGA 评估开发板支持切换下载模式，RVSTAR 仅有 FLASHXIP 模式。其中切换到 flash

模式会额外定义 VECTOR_TABLE_REMAPPED 宏，其他模式不会定义这个宏 

◼ Select C Runtime Library 对应的使用标准 C 库。在工程创建的时候，如果创建的工程采

用的是 Newlib，则这里只能进行 newlib 版本的切换，如果创建的工程才用的是 Nuclei C 

Runtime Library(libncrt)，则这里只能进行 libncrt 版本的切换。 

◼ Optimization Level 对应编译的优化等级。 
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◼ Extra Common Flags 对应的是额外的通用编译选项。可以添加额外的通用编译选项。 

◼ Extra C Flags 对应的是额外的 C 编译选项。可以添加额外的 C 编译选项。 

◼ Extra C++ Flags 对应的是额外的 C++编译选项。可以添加额外的 C++编译选项。 

◼ Extra ASM Flags 对应的是额外的汇编编译选项。可以添加额外的汇编编译选项。 

◼ Extra Link Flags 对应的是额外的链接选项。如果此选项已经有默认选项并且需要增加编

译选项，可以在编译选项开头或结尾处相隔一个空格字符再增加编译选项。 

根据需要修改以上的选项，这里我们修改优化等级为-Os 优化生成可执行文件大小。点击

save 一键修改编译选项，save 以后一定要先 clean project，之后如图 6-5，右击修改后的工程打

开右键菜单，选择“Clean Project”清理一下工程，再点击锤子图标即可完成修改编译选项后重

新编译工程。 

 

图 6-1 打开修改编译选项弹窗 1 
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图 6-2 打开修改编译选项弹窗 2 

 

图 6-3 打开修改编译选项弹窗 3 
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图 6-4 一键修改编译选项 
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图 6-5 清理工程并重新编译工程 

这里的 SDK Configuration Tool 切换不会对 Debug Configuration 选项做任何改动，因此如

果切换了 Core 以后，对应的调试配置(OpenOCD/QEMU/JLink)也需要手动修改。 

需要注意的是如果要切换工程从 32 位变为 64 位，需要打开调试设置页面，如图 7-6，修改

“command”中“set arch riscv:rv32”为“set arch riscv:rv64”，从 64 位切换回 32 位也应当

修改这里的参数为对应的数值。 

6.2.在 Nuclei Studio 中编译 Hello World 项目 

在 Nuclei Studio 中编译的步骤如下。 

◼ 为了保险起见，建议先将项目清理一下。如图 6-6 所示，在 Project Explorer 栏中选中

hello_world 项目，单击鼠标右键，选择“Clean Project”。 

◼ 如图 6-7 所示，单击菜单上的锤子按钮，开始对项目进行编译。如果编译成功，则显示

如图 6-7 所示，能够看到生成可执行文件的代码体积大小，包括 text 段、data 段和 bss

段，以及总大小的十进制和十六进制数值。使用 Makefile 方式新建的工程需要在右键菜



  

 

本文件所述内容的版权为芯来科技独家所有，未经芯来科技事先书面授权，不得传播、复制或披露本文件之全部或部分内容。  页码 68 

 

单中选择“Build Project”进行编译。 

 

图 6-6 对 hello_world 项目单击右键选择“Clean Project” 
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图 6-7 单击锤子图标对 hello_world 项目进行编译 

编译成功后可以看到增加了 Debug 文件夹，如图 6-8，各文件作用如下： 

◼ hello_world.elf 是生成的可执行文件。 

◼ hello_world.hex 是生成的 Hex 文件。 

◼ hello_world.lst 是生成的 list 文件，可以看到反汇编和简单的代码分部信息。 

◼ hello_world.map 是生成的 map 文件，可以详细的看到生成的代码分布情况。 



  

 

本文件所述内容的版权为芯来科技独家所有，未经芯来科技事先书面授权，不得传播、复制或披露本文件之全部或部分内容。  页码 70 

 

 

图 6-8 查看编译后的生成文件 

7. 调试运行项目 

7.1.使用蜂鸟调试器结合 OpenOCD 调试运行项目 

7.1.1. 安装蜂鸟调试器驱动 

Nuclei Studio 自 2021.02 版本起 openocd 实现 windows 免驱功能，使用此版本及以上

windows 环境的用户可跳过此节，Linux 环境仍需配置驱动。低于此版本的用户需按照以下方法

安装驱动。 

7.1.1.1 在 Windows 系统中安装驱动 

程序编译成功后，便可以将程序下载到 FPGA 原型开发板运行。首先将原型开发板与主机 PC

进行连接，步骤如下。 

◼ 将蜂鸟调试器的一端插入主机 PC 的 USB 接口，另一端与原型开发板连接。注意：如果
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是第一次使用蜂鸟调试器，为了使得主机 PC 的 Windows 系统能够识别蜂鸟调试器的

USB，需要安装驱动，双击如图 1-2 所示的 NucleiStudio_IDE 文件包中的 HBird-

Driver.exe 即可完成此驱动的安装。 

◼ 由于蜂鸟调试器还包含了“将原型开发板输出的 UART 转换成 USB”的功能，因此如果

蜂鸟调试器被主机 PC 识别成功（且驱动安装成功），那么将能够被主机识别成为一个

COM 串口。 

⚫ 如图 7-1 所示，在主机 PC 的设备管理器中的“端口（COM 和 LPT）栏目”中可以查

询到该 COM 的串口号（譬如 COM11）。 

⚫ 此串口在后续的程序运行过程中将充当原型开发板运行程序的 printf 输出显示接口。 

  

图 7-1 在设备管理器中查询 COM 串口号 

注意：在通过“蜂鸟调试器”下载之前，需要注意“蜂鸟调试器”被 Windows 正确识别，检

验的标准即为本节中所述正确地安装了 HBird-Driver.exe 的驱动，且能够在设备管理器中查询到
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COM 的串口号。 

7.1.1.2 在 Linux 系统中安装驱动 

在 Linux 环境下安装驱动步骤如下： 

◼ 1：连接开发板到 Linux 中，确保 USB 被 Linux 识别出来。如果使用虚拟机，如图 7-2，

确保开发板连到了虚拟机当中。 

◼ 2：在控制台中使用 lsusb 指令查看信息，参考的打印信息如下： 

Bus 001 Device 010: ID 0403:6010 Future Technology Devices International, Ltd 

FT2232xxxx 

◼ 3：控制台中输入 sudo vi /etc/udev/rules.d/99-openocd.rules 指令打开 99-

openocd.rules 文件，输入如下内容，保存退出。 

SUBSYSTEM=="usb", ATTR{idVendor}=="0403", 

ATTR{idProduct}=="6010", MODE="664", GROUP="plugdev" 

SUBSYSTEM=="tty", ATTRS{idVendor}=="0403", 

ATTRS{idProduct}=="6010", MODE="664", GROUP="plugdev" 

◼ 4：断开调试器再重新连接到 Linux 系统中。 

◼ 5：使用 ls /dev/ttyUSB*命令查看 ttyUSB 信息，参考输出如下：/dev/ttyUSB0 

/dev/ttyUSB1 

◼ 6：使用 ls -l /dev/ttyUSB1 命令查看分组信息，参考输出如下: crw-rw-r-- 1 root plugdev 

188, 1 Nov 28 12:53 /dev/ttyUSB1 

可以看到 ttyUSB1 已经加入 plugdev 组，接下来我们要将自己添加到 plugdev 组（不同

环境可能名字不同，请根据实际情况修改）。使用 whoami 命令查看当前用户名，我们

将其记录为< your_user_name >。 
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◼ 7：使用 sudo usermod -a -G plugdev <your_user_name>命令将自己添加进 plugdev

组。加入以后一定要重启或者注销操作系统。 

◼ 8：再次确认当前用户名已属于 plugdev 组，使用 groups 命令，可以看到打印信息中有

plugdev 即成功将当前用户添加至 plugdev 组。如果没有可以尝试重启。 

 

图 7-2 开发板连接至虚拟机中 

◼ 9：查看 gcc 的依赖是否完整 

cd NucleiStudio/toolchain/gcc/bin/ 

ldd ./riscv-nuclei-elf-gdb 

 

如图有依赖需要安装，可以执行 sudo apt install libncursesw5 libtinfo5进行安装 

7.1.2. 新建并配置 Debug Configuration 

通过 Nuclei Studio 新建并配置 Debug Configuration 内容的步骤如下。 
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◼ 如图 7-3 所示，在菜单栏中选择“Run—>Debug Configurations”。 

◼ 如图 7-4 所示，在弹出的窗口中，如果没有当前工程的调试设置内容，右键单击“GDB 

OpenOCD Debugging”，选择“New”，将会为本项目新建出一个调试项目

“hello_world_demo Debug”，如图 7-5 所示。确保“Project”是当前需要调试的工

程，“C/C++ Application”中选择了正确的需要调试的 ELF 文件。 

◼ 如图 7-6 所示，选择调试项目“hello_world_demo Debug”的 Debugger 菜单，在

Config options 栏目中填入-f 

"nuclei_sdk/SoC/demosoc/Board/nuclei_fpga_eval/openocd_demosoc.cfg"，以确保

OpenOCD 使用正确的配置文件。这里的配置文件

(nuclei_sdk/SoC/demosoc/Board/nuclei_fpga_eval/openocd_demosoc.cfg)根据实际

工程中 openocd 的配置文件路径而定。例如：如果使用 makefile 方式导入工程，修改此

处的内容为-f “SoC/demosoc/Board/nuclei_fpga_eval/openocd_demosoc.cfg”。 

如果当前内核是 RISC-V 32 位内核，请确保 Commands 内容包含 set arch riscv:rv32  

如果当前内核为 64 位，应确保替换为 set arch riscv:rv64 

◼ 如图 7-7 所示，选择调试项目“hello_world_demo Debug”的 Startup 菜单，确保

“Debug in RAM”,“Pre-run/Restart reset”,“Set Breakpoint at Main”和

“Continue”被勾选。 

◼ 如图 7-7，完成后点击右下方“Apply”保存设置。 
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图 7-3 单击“Run Configuration”进行下载 

 

图 7-4 添加新的 GDB OpenOCD Debugging 
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图 7-5 GDB OpenOCD Debugging 栏目下的 hello_world 项目 Debug 

  

图 7-6 配置 hello_world_demo Debug 的参数 1 
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图 7-7 配置 hello_world_demo Debug 的参数 2 

7.1.3. 在原型开发板上调试程序 

在开发板上调试之前，需要打开串口以便观察 Printf 函数打印信息。 

使用 Windows 系统打开串口的方法如下： 

◼ 打开 Nuclei Studio 自带的串口打印通道，选择 Window>Show View>Terminal，如图 

7-8 所示，点击显示器图标打开串口设置选项。如图 7-9 所示，在其窗口中设置 Choose 

terminal（选择串口，即 Serial Terminal）、“串口号”（这里以 COM11 为例）、“波

特率（设置为 115200）”等参数后，单击“OK”按钮。 
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图 7-8 通过 Nuclei Studio 打开串口调试助手并配置参数 

 

图 7-9 设置串口参数 
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使用 Linux 系统打开串口方法如下： 

◼ 打开 Nuclei Studio 自带的 Terminal 终端，选择 Window>Show View>Terminal，如图 

7-8 所示，点击显示器图标打开串口设置选项。如图 7-10 所示，choose terminal 选择

Local Terminal，点击 OK 打开 Terminal 终端。如图 7-11 所示，输入“minicom 

/dev/ttyUSB1 115200”打开串口，即可在 Nuclei Studio 中查看串口打印信息。 

 

图 7-10 打开 Terminal 终端 

 

图 7-11 打开串口 
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如果程序员希望能够调试运行于原型开发板中程序，可以使用 Nuclei Studio IDE 进行调试。

由于 IDE 运行于主机 PC 端，而程序运行于原型开发板上，因此这种调试也称为“在线调试”或

者“远程调试”。 

这里以 1_helloworld 为例，使用 Nuclei Studio IDE 对 Demosoc 原型开发板进行在线调试的

步骤如下。 

◼ 确保 6.2 节中的 Debug 设置内容正确，可以打开 Debug 设置选项确认。如图 7-12 所

示，在 1_helloworld 工程处右击，选择“Debug As –>Debug Configuration”打开

Debug 设置页面选择之前新建的设置进行检查。 

◼ 确定设置无误后，在图 7-13 的下拉框选中 Debug，之后左侧图标会变为甲虫图标，单击

即可进入调试模式并下载程序进入开发板中。 

 

图 7-12 单击“Debug Configuration”进行下载 
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图 7-13 切换至 Debug 模式 

◼ 如果下载成功，则如图 7-14 所示，并且会启动调试界面。 

⚫ 如图 7-14 的 1 号标注位置，这里功能包括单步，运行，汇编级调试等。 

⚫ 如图 7-14 的 2 号标注位置，这个箭头表示当前程序运行位置。 

⚫ 如图 7-14 的 3 号标注位置，在代码的左侧双击即可在该行设置断点，再次双击可以

取消断点。 

⚫ 如图 7-14 的 4 号标注位置，这里可以切换编辑模式和调试模式。 

⚫ 如图 7-14 的 5 号标注位置，这里是函数内变量显示的位置。 

⚫ 如图 7-14 的 6 号标注位置，这里是查看寄存器数值的位置。图中显示的是 PC 寄存

器当前的数值。 

⚫ 如图 7-14 的 7 号标注位置，点击这里红色按钮可以退出调试模式。 
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⚫ 如图 7-14 的 8 号标注位置的下方，这里可以使用 GDB 控制台指令进行调试。 

 

图 7-14 下载完成后进入调试界面 

7.1.4. 下载运行程序 

调试程序没有出现问题后，可以将程序下载进开发板。如图 7-15，点击下拉框切换至运行模

式，此时左侧图标会切换为绿色运行按键，单击即可将程序下载至开发板并运行。由于调试和下

载运行使用相同的设置文件，所以不需要再次设置。如图 7-16，可以看到串口正确打印出

helloworld 等信息。需要断开连接，如图 7-17，在 console 栏目下点击红色按钮断开连接。 



  

 

本文件所述内容的版权为芯来科技独家所有，未经芯来科技事先书面授权，不得传播、复制或披露本文件之全部或部分内容。  页码 83 

 

 

图 7-15 下载程序到开发板中运行 

 

图 7-16 串口调试助手界面输出的 Hello World 
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图 7-17 下载完成单击红色按钮断开连接 

7.2.使用 J-Link 调试运行项目 

7.2.1. 安装 J-Link 驱动并导入 RTT 文件 

HummingBird Evaluation Board 也支持使用 J-Link 调试。前往 SEGGER 官网 J-Link 页面

(https://www.segger.com/downloads/jlink/#J-LinkSoftwareAndDocumentationPack)，根据自

己的操作系统下载最新的 J-Link 驱动并安装。注意，J-Link 的版本必须高于 v6.62 版本。 

如果使用串口进行打印输出，则可以略过本节后续内容。如果想使用 J-Link 的 RTT 打印输

出，请按照以下步骤配置。 

打开当前工程的设置页面，如图 7-18，在“Resource”选项点击红框标注的图标快速打开工

程所在的目录。如图 7-19，在“nuclei_sdk/SoC/demosoc/Common/Source/Stubs”路径下新

建一个“SEGGER”文件夹，此文件夹用来存放 RTT 相关文件。 

https://www.segger.com/downloads/jlink/#J-LinkSoftwareAndDocumentationPack
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图 7-18 打开工程所在目录 

 

图 7-19 新建“SEGGER”文件夹 
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安装完成后打开 J-Link 驱动的根目录，将“Samples -> RTT”路径下的

“SEGGER_RTT_V680d.zip”解压缩（具体压缩包名可能因版本不同而变化）。解压缩后文件

内容如图 7-20，将 RTT 文件夹下的“SEGGER_RTT.c”，“SEGGER_RTT.h”和

“SEGGER_RTT_Conf.h”三个文件以及 Syscalls 文件夹下的

“SEGGER_RTT_Syscalls_GCC.c”这些文件复制到之前新建的 SEGGER 文件夹中，最后如图 

7-21 所示。在 IDE 中打开“SEGGER_RTT_Syscalls_GCC.c”，如图 7-22，注释“#include 

<reent.h>”所在的这一行。 

 

图 7-20 压缩包内文件内容 
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图 7-21 复制后 SEGGER 文件夹内容 

 

图 7-22 注释不使用的头文件 
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文件添加完成后添加 SEGGER 文件夹路径至 include，如图 7-23，打开当前工程的设置页

面，添加 SEGGER 文件夹路径至 include 中。 

 

图 7-23 添加 SEGGER 文件夹路径至 Include 中 

接下来移除原有的 write 函数。如图 7-24，在

“nuclei_sdk/SoC/hbird/Common/Source/Stubs”下的“write.c”文件处右击，选择

“Resource Configurations –> Exclude from Build”。如图 7-25，选择“Select All”，点击

“OK”。以后如果想切换回使用串口打印，可以使用相同的方式移除 SEGGER 文件夹并把

“write.c”文件添加回工程。 
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图 7-24 打开 Exclude from Build 

 

图 7-25 移除 write.c 文件 

7.2.2. 新建并配置 Debug Configuration 

新建并配置 J-Link 调试下载的 Debug Configuration 步骤如下： 
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◼ 在菜单栏中选择“Run—>Debug Configurations”。 

◼ 如图 7-26，在弹出的窗口中，如果没有当前工程的调试设置内容，右键单击“GDB 

SEGGER J-Link Debugging”，选择“New Configuration”，将会为本项目新建出一个

调试项目“1_helloworld Debug”，如图 7-27。确保“Project”是当前需要调试的工

程，“C/C++ Application”中选择了正确的需要调试的 ELF 文件。 

 

图 7-26 新建 J-Link Debug Configuration 
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图 7-27 确保 Project 和 C/C++ Application 与工程一致 

打开 Debugger 栏目，如图 7-28。 

确保 1 号位置“Start the J-Link GDB server locally”被选中。 

2 号位置正确指向 JLinkGDBServerCL.exe 的路径。 

3 号内是当前使用的内核，这里以 N307 为例，输入 N307 即可。如果使用 RV-STAR 开发

板，这里输入 GD32VF103VBT6。如果使用其他开发板请参考 J-Link Support Device 网页，链接

如下：https://www.segger.com/downloads/supported-devices.php 

4 号选择“Interface”为 JTAG，“initial speed”为 Auto。 



  

 

本文件所述内容的版权为芯来科技独家所有，未经芯来科技事先书面授权，不得传播、复制或披露本文件之全部或部分内容。  页码 92 

 

5 号确认与使用的 GDB 设置一致。 

如果有修改的内容，点击 6 号位置“Apply”保存。 

 

图 7-28 设置 Debugger 栏目内容 

打开“Startup”栏目，如图 7-29，确保 JTAG/SWD Speed 为 Auto，“set Breakpoint at 

main”，“Continue”，“Pre-run/Restart reset”和“RAM application”选项被勾选，并且取

消勾选“Initial Reset and Halt”选项。 
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图 7-29 设置 Startup 栏目内容 

以上设置内容完成后，如果有变动需要点击右下角 Apply 保存设置，如果没有变动点击 close

即可。 

7.2.3. 在原型开发板上调试程序 

使用 J-Link 在 HummingBird Evaluation Board 调试需要连接跳线。如图 7-30，红框标注的

部分是 J-Link 需要连接到板子的部分。其中 VTref 连接到板子上 V3.3 的接口，其他部分连接到

JTAG 接口，各引脚的丝印就在旁边，一一对应连接即可，最后实物连接如图 7-31。 
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图 7-30J-Link 引脚图 

 

图 7-31J-Link 实物连接图 
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在开发板上调试之前，如果使用串口打印，需要连接 JTAG 上的串口引脚到自己的主机上，

再打开串口以便观察 Printf 函数打印信息。如果使用 RTT 打印，需要打开 J-Link RTT Viewer 查

看 printf 打印信息。如图 7-32，按照图中内容设置，选择 USB 方式连接。Specify Target Device

根据使用的内核来修改，这里以 N307 为例。Target Interface & Speed 设置为 1000kHz，可根

据实际使用情况来修改。RTT Control Block 选择 Auto Detection。 

 

图 7-32 设置 RTT Viewer 

图 7-33 中下拉框选中 Debug，之后左侧图标会变为甲虫图标，单击即可进入调试模式并下

载程序进入开发板中。 

如果下载成功，则如图 7-34 所示，并且会启动调试界面。 



  

 

本文件所述内容的版权为芯来科技独家所有，未经芯来科技事先书面授权，不得传播、复制或披露本文件之全部或部分内容。  页码 96 

 

◼ 如图 7-34 的 1 号标注位置，这里功能包括单步，运行，汇编级调试等。 

◼ 如图 7-34 的 2 号标注位置，这个箭头表示当前程序运行位置。 

◼ 如图 7-34 的 3 号标注位置，在代码的左侧双击即可在该行设置断点，再次双击可以取消

断点。 

◼ 如图 7-34 的 4 号标注位置，这里可以切换编辑模式和调试模式。 

◼ 如图 7-34 的 5 号标注位置，这里是函数内变量显示的位置。 

◼ 如图 7-34 的 6 号标注位置，这里是查看寄存器数值的位置。 

◼ 如图 7-34 的 7 号标注位置，点击这里红色按钮可以退出调试模式。 

◼ 如图 7-34 的 8 号标注位置下方，这里可以使用 GDB 控制台指令进行调试。 

 

图 7-33 切换至下载模式 
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图 7-34 下载完成后进入调试页面 

7.2.4. 下载运行程序 

调试程序没有出现问题后，可以将程序下载进开发板。如图 7-35，点击下拉框切换至运行模

式，此时左侧图标会切换为绿色运行按键，单击即可将程序下载至开发板并运行。由于调试和下

载使用相同的设置文件，所以不需要再次设置。如图 7-36，可以看到 RTT Viewer 正确打印出

helloworld 等信息。如果需要断开连接，如图 7-37，在 console 栏目下点击红色按钮即可断开连

接。 
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图 7-35 下载程序到开发板中运行 

 

图 7-36 打印输出 Hello World 
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图 7-37 下载完成单击红色按钮断开连接 

8. 导入旧版本 Nuclei Studio 创建的工程 

Nuclei Studio 从 2020.08 版本开始，官方工具链从 GNU MCU RISC-V GCC (riscv-none-

embed-gcc)升级到 RISC-V Nuclei GCC (riscv-nuclei-elf-gcc)，因为编译前缀发生变化，所以使用

201909 及其之前版本的 IDE 生成的工程，经过调整设置后才可以在新版本 IDE 中使用。这里以

201909 版本的 Nuclei Studio 生成的 helloworld 工程为例，其导入及修改设置的详细步骤如下： 

◼ 导入 201909 版本生成的 helloworld 工程，详细的导入方式请参考 5.2 节，这里不做赘

述。 

◼ 导入工程后右击选择“Properties”打开设置页面，选择“C/C++ Build → Settings”，

打开 Toolchains 栏目然后修改 Name 下拉选项为“RISC-V Nuclei GCC (riscv-nuclei-elf-

gcc)”，如所示。修改后点击 Apply 保存修改。 
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图 8-1 修改 Nuclei Studio 工具链 

◼ 修改后右击工程选择“Clean Project”再选择“Build Project”即可。 

 

9. 常见问题 

9.1.Nuclei Studio 启动慢 

Nuclei Studio 是基于 eclipse 进行开发，继承了 eclipse 的可扩展性的特点的是同时，也存在

着启动较慢的问题，第一次启动时，软件需要验证环境；生成常用的缓存文件；创建 Workspace.

在 2021.09 版的 Nuclei Studio 中，我们针对启动做了优化，在电脑性能足够的前提下，第一次启

动 Nuclei Studio 能在一分钟内完成。 

Nuclei Studio 最佳运行环境： 
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◼ Windows 10 操作系统 

◼ 4G 以上内存（2G 可以被 Nuclei Studio 分配使用） 

 

9.2.Nuclei Studio 编译程序很慢 

在测试使用过程中，我们发现 Nuclei Studio 在编译项目时会出现很慢的现像，经过排查发

现，当电脑安装 360 杀毒软件时，编译指令执行很慢，退出 360 杀毒软件时，编译指令可以按正

常速度执行。为了保障 Nuclei Studio 的正常使用，建议在使用时退出 360 等杀毒软件。 

9.3.打开/关闭 Launch Bar 

打开菜单栏“Window -> Preferences”，搜索“bar”，如图 9-1，取消勾选第一个选项即可

关闭 Launch Bar。同理，想要使用 Launch Bar 功能，请勾选此选项。 

 

图 9-1 关闭 Launch Bar 

9.4.使用 Launch Bar 

Smartchip Studio 的 Launch Bar（下图中蓝色框内标注部分）是对后边下拉框中选中的调试
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配置对应的工程进行编译、调试和下载等操作，如需使用此部分请注意，图标是与下拉框中调试

配置内容相绑定。下面详细介绍 Launch Bar 各部分功能： 

 

图 9-2Launch Bar 功能介绍 

图标 1：编译选中的调试配置对应的工程。此处选中的工程为 5 号下拉框选中的调试配置对

应工程，并非 Project Explorer 中选中的工程。 

图标 2：运行/调试选中的调试配置对应的工程。此处图标会根据下拉框 4 的内容变化。 

图标 3：退出下载/调试模式。 

下拉框 4：切换选择下载/调试模式。切换后会改变图标 2 的显示内容。 

下拉框 5：选中调试配置文件。此处的内容会影响图标 1、2、3 对应的工程。 

齿轮图标 6：打开当前选中的调试配置页面，可直接进行修改保存。 

9.5.不使用 Launch Bar 进行运行/调试 

对于初次新建的工程，如果不使用 Launch Bar 功能，可以右键工程，选择“Debug As -> 

Debug Configurations”。在弹窗中选择工程对应的设置选项，这里以 helloworld 工程为例，如

图 9-3，选择“helloworld_debug_openocd”，之后选择“Debug”开始调试。 

同理，初次运行需要右击工程，选择“Run As -> Run Configurations”。在弹窗中选择工程

对应的设置选项，之后选择“Run”开始运行。 
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图 9-3 不使用 Launch Bar 首次进行调试 

若当前工程已按以上方式进行过调试或运行操作，可在上方按键中选择 的下拉选项，快

速选择对应的工程设置进行调试。对于运行，可以在 的下拉选项，快速选择对应的设置。 

9.6.Debug 页面查看寄存器 

进入 Debug 模式后，可能有些页面并不能第一时间找到，这里以查看寄存器栏目为例。在菜

单栏选择“Window -> Show View -> Registers”打开寄存器栏目。同样，如果想查看内存，可以

选择“Window -> Show View -> Memory”，想打开调试控制台，可以选择“Window -> Show 

View -> Debugger Console”，其他页面此处不做过多介绍，请用户自行体验。 

9.7.Debug 页面结束进程 

在 Debug 页面要退出调试，可点击 退出调试。为防止打开多个进程导致报错，在 Debug

页面，右击 Debug 栏目中的进程，选择“Terminate / Disconnect All”关闭所有 Debug 进程。 
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9.8.Nuclei Studio 工具栏中各按键功能 

在 Nuclei Studio 中，常见的工具栏图标如下，本节将依次介绍各按键的功能。 

 

新建按键 ，包括新建各种文件和工程。 

保存当前文件 和保存所有未保存文件 。 

切换编译设置 ，默认只有 Debug 和 Release，用户可自行添加，这里不做介绍。 

编译工程 ，可以在下拉选项中编译 Project Explorer 中选中的工程。 

编译所有工程 ，一次性编译所有 Project Explorer 中的工程。 

新建功能 ，包含工程创建，目录创建，文件创建和类创建。 

调试 ，可根据下拉选项选择不同调试设置来调试不同的工程。 

运行 ，可根据下拉选项选择不同的设置来选择不同的工程。 

Profile ，使用 Profile 功能，暂不支持，此处不做介绍。 

用户自定义工具 ，此处不做介绍，用户可自己深入研究。 
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搜索工具 ，可搜索任务，文本等。 

文本阅读工具 ，可以展开或折叠文本等功能。 

控制台工具 ，可选择打开各种控制台或串口等。 

Debug 用 ，前者跳过所有断点，后者实现 Restart 功能。 

查看 CMSIS ，eclipse 自带功能，暂不支持。 

Nuclei SDK 工程设置工具 ，参见 6.1。 

文本阅读工具 ，可设置快速跳转，具体功能此处不作过

多介绍。 

9.9.显示其他窗口 

在 IDE 的右上角 按键可以切换不同的显示模式，常用的是 C/C++页面和 Debug 页面。其

中，在进入 Debug 模式时，若不在 Debug 页面，会有弹窗提示，此时点击“Switch”选项可以

切换至 Debug 页面。在菜单栏中选择“Window -> Perspective -> Open Perspective”可以快速

切换显示窗口。 

在不同的窗口下，“Window -> Show View”显示的内容也不尽相同。如图 9-4，在 Debug

窗口中可以选择显示如寄存器（Registers），内存（Memory）和调试控制台（Debugger 

Console）。 
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图 9-4Debug 模式查看功能窗口 

9.10. 恢复默认窗口布局 

在菜单栏中选择“Window -> Perspective -> Reset Perspective”，在弹窗中选择“Reset 

Perspective”可以恢复窗口默认布局。 

9.11. 对比历史文件 

右击要查看历史的文件，选择“Compare With -> Local History”打开历史记录。如图 

9-5，在打开的 History 栏目双击选择要对比的文件历史版本，可以查看文件变动历史。 
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图 9-5 对比历史文件 

9.12. 新建工程时可能出现报错 

新建工程时 IDE 需要索引整个工程，根据主机性能其所用时间不同。如果主机性能较差，可

能会看到索引时产生 error，索引结束后 error 会消失。如出现以上现象，请以编译时是否报错为

准。 

9.13. 新增 Include 路径出现缓存 

在 include 页面新增路径时，可能会出现缓存的路径内容，此时点击 Workspace 或 File 

System 选中后可覆盖其内容。 

9.14. 设置页面栏目找不到 

有时可能因为弹窗大小，部分设置栏目被隐藏起来，如图 9-6，可点击红框中左右方向图标

显示隐藏栏目。 
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图 9-6 显示隐藏栏目 

9.15. 开发板下载速度很慢 

如果遇到开发板下载速度很慢，甚至出现超时的报错，请切换至使用 USB3.0 接口，如果使

用虚拟机开发，也请同时将 USB 接口设置为 3.0。 

9.16. Linux 环境下多用户使用 Nuclei Studio 

如果需要多用户同时使用 Nuclei Studio（不推荐），用户在运行 Nuclei Studio 时首先要打

开菜单栏的“Window->Preferences”。在弹窗中需要修改三个地方： 

⚫ 打开“MCU->Global OpenOCD Path”，“Executable”输入“openocd”，“Folder”

输入“${eclipse_home}/toolchain/openocd/bin”。 

⚫ 打开“MCU->Global QEMU Path”，“Executable”输入“qemu-system-riscv32”，

“Folder”输入“${eclipse_home}/tools/qemu”。 

⚫ 打开“MCU->Global RISC-V Toolchains Paths”，“Default toolchain”选中“RISC-V 
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Nuclei GCC”，“Toolchain folder”输入“${eclipse_home}/toolchain/gcc/bin”。 

修改后点击“Apply and Close”保存并关闭设置弹窗。 

9.17. 设备管理器中识别出两个串口 

可能连接设备后在任务管理器中识别出两个串口，如图 9-7，其中 COM 编号较大的是串口打

印使用，可以使用串口调试助手等工具连接查看打印信息，但是请不要占用 COM 编号较小的串

口。 

 

图 9-7 设备管理器中显示两个串口 

9.18. Linux 下使用时报 Could not determine GDB version after 

sending:riscv-nuclei-elf-gdb –version,response:的错误 

第一次在 linux 下使用 NucleiStudio 时，会报错 Could not determine GDB version after 

sending:riscv-nuclei-elf-gdb –version,response:，如图 
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可以使用命令 ldd riscv-nulcei-elf-gdb 查看，依赖缺失 

 

使用命令 sudo apt install libncursesw5 libtinfo5 安装相关依赖后，ide 运行正常，具体可以

参考 https://github.com/riscv-mcu/riscv-gnu-toolchain/issues/9 

 

10.Nuclei Studio 升级 

一般情况下，如果 Nuclei Studio 没有大的版本变动，Nuclei Studio 升级工作可以由用户下

载最新的 GNU 工具链以及其他相关工具和升级 IDE Plugins 的方式来完成。 

10.1. GCC/OpenOCD 等工具链的安装 

Nuclei Studio 已经把工具链集成在 IDE 内部，工具链存放在 NucleiStudio_IDE_XXX 文件

夹内，路径为：NucleiStudio_IDE_XXX\NucleiStudio\toolchain。IDE 默认使用此路径的工具

链，所以请不要移动“toolchain”此文件夹，使用 IDE 创建工程后也不需要进行工具链的相关配
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置。 

由于工具链升级的速度会比 IDE 快，所以后期需要用户手动升级工具链，工具链升级方法如

下： 

◼ 首先删除需要更新的 GCC 或者 OpenOCD 文件内的内容，然后在芯来科技官网下载最新

版本的 GCC 或者 OpenOCD。 

◼ 将 GCC 或者 OpenOCD 的内容复制到对应的文件夹下，即可完成 IDE 工具链的更新，

IDE 自带的工具链的版本号记录在 ReadMe.txt 中，如图 10-1 所示。注意：要保证 gcc

所在的这一级目录文件夹名字不变，替换后保证 bin 文件夹所在层级是图中文件夹的子

目录，中间不要有其他文件夹。 

 

图 10-1IDE 工具链路径 

10.2. IDE Plugins 升级 

Nuclei Studio 支持 IDE 内在线升级，步骤如下。 

◼ 如图 10-2，打开安装软件弹窗，在菜单栏选择“Help → Install New Software”。 

◼ 如图 10-3，点击“already installed”打开已安装界面。 

◼ 如图 10-4，选择“Nuclei Studio”，点击“update”即可自动完成在线更新。 
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图 10-2 打开安装软件弹窗 
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图 10-3 打开已安装界面 
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图 10-4 选择“Nuclei Studio”更新 

11.使用 QEMU 仿真调试 

最新版本的 Nuclei Studio 整合了 QEMU，支持 GD32VF103 和芯来全系列 Core 的工程实现

仿真调试功能，这里以 RVSTAR 工程为例。 

按照前文的内容新建一个 RVSTAR 工程，这里以 helloworld 工程为例，我们新建一个名为
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helloworld 的工程。 

右击新建的工程，选择“Debug As -> Debug Configurations”打开调试设置弹窗。如图 

11-1，在弹窗中选择“GDB QEMU Debugging”下带有“qemu”后缀的设置选项。我们工程为

“helloworld”，所以此处选择“helloworld_debug_qemu”，选中后点击右下方的“Debug”

开始仿真调试。 
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图 11-1 选择 QEMU 进行仿真调试 

QEMU 的详细配置页，新增了 Machine Bit、Board name、Nuclei RISC-V Core、Download

选项，用户可以在这里对 QEMU 进行自定义配置。 

◼ Machine Bit QEMU 可以仿真 32 位和 64 位两种设备 

◼ Board name 针对不同的 Board 有不同的外设及配置 
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◼ Nuclei RISC-V Core  QEMU 已经支持当前 nuclei 大多数的处理器型号，并会持续更

新，支持更多的最新处理器的型号。下面展示了支持的 CPU 型号的情况。 

 

◼ Download QEMU 仿真了不同的下载模式 

备注：2021.09 版的 Nuclei Studio 对之前版本的 Nuclei Studio 创建的工程的 qemu 部分不兼容 

如图 11-2 所示，仿真调试页面与一般的调试页面完全相同，其中，串口打印信息可直接在

Console 中查看。寄存器可能有部分未实现的会报错，属于正常现象。 
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图 11-2QEMU 仿真调试界面 

仿真运行流程与仿真调试相类似，右击 RVSTAR 工程选择“Run As -> Run Configurations”，

弹窗中选择“GDB QEMU Debugging”下带有“qemu”后缀的设置选项。选中后点击“Run”，

可以在控制台（Console 栏）看到运行的打印输出。 

12.创建并贡献 Nuclei Studio 组件包 

Nuclei Studio 2022.04 版中，提供了一个非常重要的功能，该功能主要通过提供的各种初始模

板，方便开发者去创建自己的 Nuclei Studio 组件包，并可以通过平台将自己的 Nuclei Studio 组件

包贡献出来，供其他开发者使用。具体可以参考在线文档 

在线文档：https://www.rvmcu.com/nucleistudio-userguide-id-27.html 


	版权声明
	联系我们
	修订历史
	目  录
	图片清单
	1. Nuclei Studio IDE简介与安装
	1.1.  Nuclei Studio IDE简介
	1.2.  Nuclei Studio IDE下载
	1.3.  Nuclei Studio IDE安装

	2. 启动Nuclei Studio
	3. Nuclei Studio更新说明
	4. Nuclei Studio NPK功能
	4.1. 通过NPK创建工程
	4.2. 通过NPK导入工具

	5. 创建项目
	5.1. 通过模板自动创建项目
	5.2. 从已有项目直接导入创建新项目
	5.3. 无模板手动创建项目
	5.3.1. 手动创建项目
	5.3.2. 配置项目的nuclei_sdk
	5.3.3. 配置项目的编译和链接选项
	5.3.4. 配置项目的包含路径和文件

	5.4. 基于已有的Makefile创建项目
	5.4.1. 手动新建项目
	5.4.2. 设置Makefile路径和Build选项


	6. 编译项目
	6.1. Nuclei SDK 工程设置工具
	6.2. 在Nuclei Studio中编译Hello World项目

	7. 调试运行项目
	7.1. 使用蜂鸟调试器结合OpenOCD调试运行项目
	7.1.1. 安装蜂鸟调试器驱动
	7.1.1.1 在Windows系统中安装驱动
	7.1.1.2 在Linux系统中安装驱动

	7.1.2. 新建并配置Debug Configuration
	7.1.3. 在原型开发板上调试程序
	7.1.4. 下载运行程序

	7.2. 使用J-Link调试运行项目
	7.2.1. 安装J-Link驱动并导入RTT文件
	7.2.2. 新建并配置Debug Configuration
	7.2.3. 在原型开发板上调试程序
	7.2.4. 下载运行程序


	8. 导入旧版本Nuclei Studio创建的工程
	9. 常见问题
	9.1. Nuclei Studio启动慢
	9.2. Nuclei Studio编译程序很慢
	9.3. 打开/关闭Launch Bar
	9.4. 使用Launch Bar
	9.5. 不使用Launch Bar进行运行/调试
	9.6. Debug页面查看寄存器
	9.7. Debug页面结束进程
	9.8. Nuclei Studio工具栏中各按键功能
	9.9. 显示其他窗口
	9.10. 恢复默认窗口布局
	9.11. 对比历史文件
	9.12. 新建工程时可能出现报错
	9.13. 新增Include路径出现缓存
	9.14. 设置页面栏目找不到
	9.15. 开发板下载速度很慢
	9.16. Linux环境下多用户使用Nuclei Studio
	9.17. 设备管理器中识别出两个串口
	9.18. Linux下使用时报Could not determine GDB version after sending:riscv-nuclei-elf-gdb –version,response:的错误

	10. Nuclei Studio升级
	10.1. GCC/OpenOCD等工具链的安装
	10.2. IDE Plugins升级

	11. 使用QEMU仿真调试
	12. 创建并贡献Nuclei Studio组件包

